Kind Kiosk - Backend Systems unavailable – Incident details

All systems operational

Backend Systems unavailable

Resolved
Major outage
Started 9 days agoLasted 2 minutes

Affected

Backend Systems

Operational from 9:27 PM to 9:27 PM, Major outage from 9:27 PM to 9:28 PM

Updates
  • Resolved
    Resolved
    Our Backend Systems have fully recovered.
  • Investigating
    Investigating
    We are investigating an issue with our Backend Systems.